Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 07-30-07, 08:29 PM   #1
gfxdrone
Registered User
 
Join Date: Feb 2007
Posts: 74
Exclamation udev vs. proprietary NVIDIA driver in Debian

Debian bug 435250

Quote:
dev 0.113-1 mounts /dev noexec, and this breaks the proprietary NVIDIA driver.

So far I am inclined to revert the change, but I am soliciting opinions about applications mmap'ing PROT_EXEC /dev/zero and if it is a good idea and should be allowed, or not.
http://blog.bofh.it/id_128

Debian bug 435186

We haven't seen this come in yet, but it's expected soon. Is this something that Nvidia is already aware of? If not, here's the links you need.

I'll be testing to confirm this, or to see if current udev package 0.113-2 has this fixed or not.

<update>I just tested this, and on debian sid, I can't see any problems with latest udev and nvidia 100.14.11 driver. It looks like noexec is not used in /dev with 0.113-2 but I can't say for certain what the status is.
gfxdrone is offline   Reply With Quote
Old 07-31-07, 08:48 AM   #2
fidojones
Registered User
 
Join Date: Jul 2007
Posts: 1
Thumbs up Re: udev vs. proprietary NVIDIA driver in Debian

I have this problem. Nvidia left of work suddenly with driver:

NVIDIA-Linux-x86-100.14.11-pkg1.run

With and x86signanling cautch error. After some probes (recompiling driver, a lof of times, using experimental packages from X) I discover and error in libglx.so. So I remove nvidia drivers, and X runs prefect.

I discover this post, and apply the fix form the bugs list in debian:

Removing noexec
/etc/init.d/udev
/etc/init.d/udev-mtab

Reinstalled the drivers, and no nvidia works again. Definitively there is a problem with nvidia drivers and noexec in UDEV.

ii udev 0.113-2 /dev/ and hotplug management daemon

Thanks for reporting I was crying without my twinview.
fidojones is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
nvidia driver quality decrease? legluondunet NVIDIA Linux 17 06-26-12 11:03 AM
Need Help Installing NVIDIA Tesla M2070Q in Linux RHEL5 Ferianto85 NVIDIA Linux 0 05-18-12 09:35 PM
Lucid rt kernel can't load latest nvidia driver module, but generic does. marcod NVIDIA Linux 0 05-02-12 07:23 AM
Getting the proprietary nvidia driver to run with Debian 3.0 r0 (woody) Katchina404 NVIDIA Linux 9 01-12-03 09:49 AM
nvidia + 2.4.19 gentoo = messed up ulukay NVIDIA Linux 18 11-02-02 12:58 AM

All times are GMT -5. The time now is 10:30 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.