Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 08-01-07, 05:46 PM   #13
netllama
NVIDIA Corporation
 
Join Date: Dec 2004
Posts: 8,763
Default Re: 100.14.11 and geforce 7025

If you need further assistance after running the above command, please describe the problem, and attach a new bug report.

Also, can you take a picture of the problem? I'm afraid that I don't understand what's happening there.
netllama is offline   Reply With Quote
Old 08-01-07, 05:48 PM   #14
wintpe
Registered User
 
Join Date: Jan 2006
Posts: 21
Default Re: 100.14.11 and geforce 7025

this is what your --twinview command generated ,

[peter@ossi41 ~]$ cat /etc/X11/xorg.conf
# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig: version 1.0 (buildmeister@builder3) Wed Jun 13 18:39:30 PDT 2007

Section "ServerLayout"
Identifier "Layout0"
Screen 0 "Screen0"
InputDevice "Keyboard0" "CoreKeyboard"
InputDevice "Mouse0" "CorePointer"
EndSection

Section "Files"
RgbPath "/usr/X11R6/lib/X11/rgb"
FontPath "unix/:7100"
EndSection

Section "Module"
Load "dbe"
Load "extmod"
Load "type1"
Load "freetype"
Load "glx"
EndSection

Section "InputDevice"
# generated from default
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "auto"
Option "Device" "/dev/input/mice"
Option "Emulate3Buttons" "no"
Option "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"
# generated from data in "/etc/sysconfig/keyboard"
Identifier "Keyboard0"
Driver "kbd"
Option "XkbLayout" "gb"
Option "XkbModel" "pc105"
EndSection

Section "Monitor"
Identifier "Monitor0"
VendorName "Unknown"
ModelName "Unknown"
HorizSync 30.0 - 110.0
VertRefresh 50.0 - 150.0
Option "DPMS"
EndSection

Section "Device"
Identifier "Device0"
Driver "nvidia"
VendorName "NVIDIA Corporation"
EndSection

Section "Screen"
Identifier "Screen0"
Device "Device0"
Monitor "Monitor0"
DefaultDepth 24
Option "TwinView" "True"
Option "MetaModes" "nvidia-auto-select, nvidia-auto-select"
SubSection "Display"
Depth 24
Modes "1600x1200" "1280x1024" "1024x768" "800x600" "640x480"
EndSubSection
EndSection


the driver however has other ideas
wintpe is offline   Reply With Quote
Old 08-01-07, 05:54 PM   #15
wintpe
Registered User
 
Join Date: Jan 2006
Posts: 21
Default Re: 100.14.11 and geforce 7025

ok ill describe it to you in detail




left screen is a 1280x1024 screen however the mouse disappears off the edge of the screen as though there is another 1280x1024 pixels hidden to the right of the screen.

the right screen is an exact shadow copy of this, as through its connected to the same output socket

when i startx imaging the nvidia logo screen being 2590 pixels wide, but only displaying the left half of it so that the nvidia logo is cut right through the middle.

the right half is displayed in this off screen half.

yet again the other monitor is an exact copy of this and thats running off the above config file.

ps please dont keep asking me to submit another problem, we are still on page 1 of the origional,

regards peter
wintpe is offline   Reply With Quote
Old 08-01-07, 05:57 PM   #16
netllama
NVIDIA Corporation
 
Join Date: Dec 2004
Posts: 8,763
Default Re: 100.14.11 and geforce 7025

Is this problem only present when doing Twinview?

I still need to see a new bug report that includes the changes that I've requested.
netllama is offline   Reply With Quote
Old 08-01-07, 06:02 PM   #17
wintpe
Registered User
 
Join Date: Jan 2006
Posts: 21
Default Re: 100.14.11 and geforce 7025

attached new bugreport and snapshot.

this is the picture that printscreen dumps, however i can only see the left half of it on both monitors.

the right half is not panable its just off screen to the right. the right hand side of my monitors is currently intersecting the middle of this browser window
Attached Thumbnails
Click image for larger version

Name:	snapshot1.jpg
Views:	107
Size:	269.8 KB
ID:	27026  
wintpe is offline   Reply With Quote
Old 08-01-07, 06:06 PM   #18
wintpe
Registered User
 
Join Date: Jan 2006
Posts: 21
Default Re: 100.14.11 and geforce 7025

it was too big so ive gzipped it
Attached Files
File Type: gz nvidia-bug-report.log.gz (28.9 KB, 125 views)
wintpe is offline   Reply With Quote
Old 08-01-07, 06:07 PM   #19
wintpe
Registered User
 
Join Date: Jan 2006
Posts: 21
Default Re: 100.14.11 and geforce 7025

yes its as soon as twinview is selected , but as with twin view both monitors are just a copy of each other ,

its basicly not transfering the righthand side of the image/canvas/desktop to the second screen
wintpe is offline   Reply With Quote
Old 08-01-07, 06:21 PM   #20
netllama
NVIDIA Corporation
 
Join Date: Dec 2004
Posts: 8,763
Default Re: 100.14.11 and geforce 7025

Please start X with the following command:
startx -- -logverbose 6

and then generate a new bug report.

thanks,
Lonni
netllama is offline   Reply With Quote

Old 08-02-07, 03:12 AM   #21
wintpe
Registered User
 
Join Date: Jan 2006
Posts: 21
Default Re: 100.14.11 and geforce 7025

will do later today when i get home
wintpe is offline   Reply With Quote
Old 08-02-07, 01:25 PM   #22
wintpe
Registered User
 
Join Date: Jan 2006
Posts: 21
Default Re: 100.14.11 and geforce 7025

OK Loni, after being up till past 12 and having to get up at 5am im calling a stop to this. im to tired to do it for another night.

ive put the 7300gs card in here with exactly the same xorg.conf and it works fine exactly as i expected and no messing around at all.

the 7025 driver does not work in twinview.... period it ignores whatever you put in the config file.
it appears that the memory gets mapped correctly to provide the double width desktop, however the second monitors D-A maps itself to the same address space scan as the first monitor, and it will not move from it.
second monitor will never see that right hand memory segment.

Loni you need to get yourselves a 7025 based board and test it , and you will see the problem as clear as day, for anyone else reading this do not buy an nvidia 7025-630a based board if you want twinview in linux, it does not work on the current release of driver, and you will spend hours on here with loni giving him log file after log file.

the only exception to this statment is i have bought a board with a hardware error preventing the programming of the second DACs map.

if anyone else out there does have one thats working please let me know and ill send the board back, but im more inclined to believe that the majority of them are running windoze and the windoze driver is not exhibiting this problem.

regards peter
wintpe is offline   Reply With Quote
Old 08-02-07, 01:28 PM   #23
netllama
NVIDIA Corporation
 
Join Date: Dec 2004
Posts: 8,763
Default Re: 100.14.11 and geforce 7025

Contrary to your assertion, X is running in Twinview, so that is clearly not the problem. I'm not sure what you mean by a "7025 driver" as you should be using the same 100.14.11 driver for both of the GPUs that you're using.

Just because something doesn't work as expected does not mean that it is a driver bug. You've not provided any information as to why you feel that this is a driver bug rather than a hardware problem.
netllama is offline   Reply With Quote
Old 08-06-07, 12:57 PM   #24
wintpe
Registered User
 
Join Date: Jan 2006
Posts: 21
Default Re: 100.14.11 and geforce 7025

within 30 mins of me posting this i started to get lockups with the 7300gs, even though all my previous issues that i had discussed with you were over now i was running on a 7300GS.
downgraded the driver to the 100.14.3 and its been fine since.
going by the amount of people on here complaining about lockups with the 11 driver, and the problems im having, which until theres a newer driver or someone else tells me their 7025 is working fine with the 11 driver im going stick with the fact it should have been tested a bit more before you released it.

and just for your info, im a BIG fan of nvidia , and when i see drivers with this level of issues, i think ATI, not nvidia.

so i really think you should go back to the lab with this driver and prove me wrong.

regards peter
wintpe is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
What You Can Expect From GeForce GRID News Archived News Items 0 06-04-12 04:20 PM
Enhance Max Payne 3, Diablo III with GeForce R300 Drivers News Archived News Items 0 05-22-12 06:30 PM
New GPU from Nvidia Announced Today, the GeForce GTX 670 News Archived News Items 0 05-10-12 01:50 PM
Gainward Unleashes the Sexy GeForce GTX 670 Phantom Graphics Card, Also launches the News Archived News Items 0 05-10-12 09:28 AM

All times are GMT -5. The time now is 08:53 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.