Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 08-02-07, 10:53 AM   #1
ahurst
Registered User
 
Join Date: Aug 2007
Posts: 22
Default 1.0-7185 AGP SBA and FW options broken [solved]

Hello,
on upgrading to 1.0.7185 for my TNT2, I find that the nvidia module no longer responds to options NVreg_EnableAGPSBA=1 and NVreg_EnableAGPFW=1 in /etc/modules.conf.

/proc/driver/nvidia/registry shows EnableAGPSBA: 0 and EnableAGPFW: 0, regardless of the state set in modules.conf.

This worked in 1.0-7184, using AGPGART.

Any suggestions?

Andy

Last edited by ahurst; 08-07-07 at 04:07 PM. Reason: typo - plural modules.
ahurst is offline   Reply With Quote
Old 08-02-07, 11:05 AM   #2
ahurst
Registered User
 
Join Date: Aug 2007
Posts: 22
Default nvidia-bug-report.log

attached nvidia-bug-report.log
Attached Files
File Type: log nvidia-bug-report.log (66.5 KB, 92 views)
ahurst is offline   Reply With Quote
Old 08-02-07, 01:17 PM   #3
zander
NVIDIA Corporation
 
zander's Avatar
 
Join Date: Aug 2002
Posts: 3,740
Default Re: 1.0-7185 AGP SBA and FW options broken

No changes were made between 1.0-7184 and 1.0-7185 that would impact these module options; are you sure the NVIDIA Linux graphics driver is the only parameter you changed?
zander is offline   Reply With Quote
Old 08-03-07, 04:00 PM   #4
ahurst
Registered User
 
Join Date: Aug 2007
Posts: 22
Default Re: 1.0-7185 AGP SBA and FW options broken

I can't be absolutely certain: the Gentoo ebuild might do something different, but I don't see how it would affect the driver's use of /etc/modules.conf.

Is there any other reason why values set in /etc/modules.conf would be ignored by the nvidia module?

I used the standard line:
Code:
options nvidia NVreg_EnableAGPSBA=1 NVreg_EnableAGPFW=1
ahurst is offline   Reply With Quote
Old 08-03-07, 04:03 PM   #5
netllama
NVIDIA Corporation
 
Join Date: Dec 2004
Posts: 8,763
Default Re: 1.0-7185 AGP SBA and FW options broken

What does 'modinfo nvidia' report?
netllama is offline   Reply With Quote
Old 08-03-07, 07:22 PM   #6
ahurst
Registered User
 
Join Date: Aug 2007
Posts: 22
Default Re: 1.0-7185 AGP SBA and FW options broken

#modinfo nvidia

filename: /lib/modules/2.6.21-gentoo-r4/video/nvidia.ko
license: NVIDIA
alias: char-major-195-*
alias: pci:v000010DEd*sv*sd*bc03sc00i00*
depends:
vermagic: 2.6.21-gentoo-r4 preempt K7
parm: NVreg_VideoMemoryTypeOverride:int
parm: NVreg_EnableVia4x:int
parm: NVreg_EnableALiAGP:int
parm: NVreg_ReqAGPRate:int
parm: NVreg_NvAGP:int
parm: NVreg_EnableAGPSBA:int
parm: NVreg_EnableAGPFW:int
parm: NVreg_SoftEDIDs:int
parm: NVreg_Mobile:int
parm: NVreg_ModifyDeviceFiles:int
parm: NVreg_DeviceFileUID:int
parm: NVreg_DeviceFileGID:int
parm: NVreg_DeviceFileMode:int
parm: NVreg_ResmanDebugLevel:int
parm: NVreg_FlatPanelMode:int
parm: NVreg_DevicesConnected:int
parm: NVreg_VideoEnhancement:int
parm: NVreg_RmLogonRC:int
parm: NVreg_RemapLimit:int
parm: NVreg_UseCPA:int
parm: NVreg_VbiosFromROM:int
parm: nv_disable_pat:int
ahurst is offline   Reply With Quote
Old 08-06-07, 03:11 AM   #7
ahurst
Registered User
 
Join Date: Aug 2007
Posts: 22
Default Re: 1.0-7185 AGP SBA and FW options broken

Still no ideas?

I have discovered that nvidia-settings is also broken.

It starts, but gives the following messages, while not displaying any device controls (those aside from nvidia-settings Configuration):

Code:
ERROR: NV-CONTROL extension version 1.6 is too old; the minimimum required version is 1.11.
ERROR: Unable to determine number of NVIDIA GPUs on ':0.0'.
ERROR: Unable to determine number of NVIDIA Frame Lock Devices on ':0.0'.
ERROR: Unable to determine number of NVIDIA VCSCs on ':0.0'.
This aswell worked with driver 1.0-7184

Andy
ahurst is offline   Reply With Quote
Old 08-06-07, 10:20 AM   #8
netllama
NVIDIA Corporation
 
Join Date: Dec 2004
Posts: 8,763
Default Re: 1.0-7185 AGP SBA and FW options broken

Please install the official NVIDIA driver package and see whether the problems persist.
netllama is offline   Reply With Quote

Old 08-06-07, 10:31 AM   #9
ahurst
Registered User
 
Join Date: Aug 2007
Posts: 22
Default Re: 1.0-7185 AGP SBA and FW options broken

Hi,
I've solved the problem with nvidia-settings and NV-CONTROL:
Gentoo's ebuild uses the latest nvidia-settings package, regardless of the nvidia-driver version. Our bad.

I will test the nvidia package when I get home.

Thanks,
Andy
ahurst is offline   Reply With Quote
Old 08-07-07, 09:59 AM   #10
ahurst
Registered User
 
Join Date: Aug 2007
Posts: 22
Default Re: 1.0-7185 AGP SBA and FW options broken

Exactly the same thing happens when installed using NVIDIA-Linux-x86-1.0-7185-pkg1.run.
ahurst is offline   Reply With Quote
Old 08-07-07, 10:08 AM   #11
netllama
NVIDIA Corporation
 
Join Date: Dec 2004
Posts: 8,763
Default Re: 1.0-7185 AGP SBA and FW options broken

Exactly what same thing happens? Did you remove/purge the non-official NVIDIA package files before installing the official driver?
netllama is offline   Reply With Quote
Old 08-07-07, 10:43 AM   #12
ahurst
Registered User
 
Join Date: Aug 2007
Posts: 22
Default Re: 1.0-7185 AGP SBA and FW options broken

I ran 'emerge -C nvidia-drivers' to remove the gentoo driver package.
I removed the nvidia.ko kernel module from /lib/modules/<kernel-ver>/video/, and rebooted.

I am running udev, so didn't think deleting any /dev nodes would be necessary,
and I kept the modules.conf entries:

Code:
alias char-major-195 nvidia
alias /dev/nvidiactl char-major-195

options nvidia NVreg_EnableAGPSBA=1 NVreg_EnableAGPFW=1

options nvidia NVreg_DeviceFileMode=432 NVreg_DeviceFileUID=0 NVreg_DeviceFileGID=27 NVreg_ModifyDeviceFiles=1
The contents of /proc/driver/nvidia/registry remained unaffected by the options in modules.conf

Andy
ahurst is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 03:29 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.