Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 08-08-07, 02:14 PM   #1
RobotMarvin
Registered User
 
Join Date: Oct 2006
Location: Germany
Posts: 77
Default console font is not properly restored after Xorg -> VT switch

Hello everyone.

Since I upgraded my system's hardware (among others) to a 8600 GTS based card, I am having the following problem: the console font isn't restored properly when I switch from Xorg to the console. Setting it again, works fine... until I switch to Xorg and back.

This also seems to depend on the fonts size. If I use smaller fonts (lat1-08 instead of lat1-16), the problem is even worse. Most of the console is cleared black and the cursor is somewhere out of screen. Clearing brings back the cursor and stuff but the screen is oversized... meaning even though the console font is back to 8x25, more rows are being used and those above 25 are just displayed outside of the visual screen. (hard to explain)

This problem doesn't seem to be very uncommon because I have been able to find reports in this forum, the gentoo forum and even bug reports.

I have attached a bug report log to this which will hopefully help resolve this issue once and for all.

Thanks for everything in advance.

Best regards,
Matthias Dahl
Attached Files
File Type: gz nvidia-bug-report.log.gz (42.1 KB, 125 views)
RobotMarvin is offline   Reply With Quote
Old 04-18-09, 09:04 AM   #2
Polynomial-C
Registered User
 
Join Date: Jul 2008
Location: germany
Posts: 4
Default Re: console font is not properly restored after Xorg -> VT switch

Hey guys, this thread is from 2007 and the problem still isn't fixed. I'm using lat9w-16 fonts in my VTs and everytime I switch from X back to a VT the fonts are reset again. This is ugly like hell especially when I want to use midnight-commander inside of a VT or want to write some german umlauts. Running
Code:
/etc/init.d/consolefonts restart
everytime I switch from X to a VT is a real PITA. Come on, fix this please.
Attached Files
File Type: bz2 nvidia-bug-report.log.bz2 (27.8 KB, 67 views)
Polynomial-C is offline   Reply With Quote
Old 04-18-09, 12:20 PM   #3
zander
NVIDIA Corporation
 
zander's Avatar
 
Join Date: Aug 2002
Posts: 3,740
Default Re: console font is not properly restored after Xorg -> VT switch

@Polynomial-C: please try the 180.51 NVIDIA Linux graphics driver release (see http://www.nvnews.net/vbulletin/showthread.php?t=131671).
zander is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 03:43 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.