Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 08-25-07, 12:58 PM   #13
AaronP
NVIDIA Corporation
 
AaronP's Avatar
 
Join Date: Mar 2005
Posts: 2,487
Default Re: Notebook & GeForce 8400M G

This bug report is from the "vesa" X driver. You'll need to start X with the nvidia driver and then capture a bug report. You can do this after a reboot if you boot to a console and generate the bug report there.
AaronP is offline   Reply With Quote
Old 08-26-07, 04:55 AM   #14
gambacherkalben
Registered User
 
Join Date: Aug 2007
Posts: 13
Red face Re: Notebook & GeForce 8400M G

Quote:
Originally Posted by AaronP
This bug report is from the "vesa" X driver. You'll need to start X with the nvidia driver and then capture a bug report. You can do this after a reboot if you boot to a console and generate the bug report there.
Ooops! "Fixed".
Attached Files
File Type: gz nvidia-bug-report.tar.gz (24.6 KB, 113 views)
gambacherkalben is offline   Reply With Quote
Old 08-26-07, 12:08 PM   #15
AaronP
NVIDIA Corporation
 
AaronP's Avatar
 
Join Date: Mar 2005
Posts: 2,487
Default Re: Notebook & GeForce 8400M G

It looks like only the 640x480 mode is getting validated. Please start X with the "-logverbose 6" option as per the sticky post and generate and attach a new bug report.
AaronP is offline   Reply With Quote
Old 08-26-07, 02:24 PM   #16
gambacherkalben
Registered User
 
Join Date: Aug 2007
Posts: 13
Unhappy Re: Notebook & GeForce 8400M G

Quote:
Originally Posted by AaronP
It looks like only the 640x480 mode is getting validated. Please start X with the "-logverbose 6" option as per the sticky post and generate and attach a new bug report.
Well, I hope that I did it right, huh? X-server crashed. Something with FreeFont or sth. like that...

Regards,
gambacherkalbenstein
Attached Files
File Type: gz nvidia-bug-report.tar.gz (24.8 KB, 134 views)
gambacherkalben is offline   Reply With Quote
Old 08-26-07, 06:49 PM   #17
AaronP
NVIDIA Corporation
 
AaronP's Avatar
 
Join Date: Mar 2005
Posts: 2,487
Default Re: Notebook & GeForce 8400M G

It didn't work right, your bug report is still missing the verbose mode validation log. What command, exactly, did you use to start the server? You need to use something like "startx -- -logverbose 6" (note two dashes, a space, and a dash).

The FreeFontPath message is a harmless warning. As far as I can tell from the log, the X server did not crash.
AaronP is offline   Reply With Quote
Old 09-01-07, 12:02 PM   #18
gambacherkalben
Registered User
 
Join Date: Aug 2007
Posts: 13
Talking Re: Notebook & GeForce 8400M G

Ok. NOW!!! Finally!!
At least I hope so...

I had a look on bug-report myself. Wow! You understand Egyptian... ;-)
Attached Files
File Type: gz nvidia-bug-report.tar.gz (32.4 KB, 113 views)
gambacherkalben is offline   Reply With Quote
Old 09-01-07, 03:58 PM   #19
netllama
NVIDIA Corporation
 
Join Date: Dec 2004
Posts: 8,763
Default Re: Notebook & GeForce 8400M G

Here's the problem:

(II) NVIDIA(0): Validating Mode "1680x1050"
(II) NVIDIA(0): 1680 x 1050 @ 61 Hz
(II) NVIDIA(0): For use as DFP backend.
(II) NVIDIA(0): Mode Source: EDID
(II) NVIDIA(0): Pixel Clock : 121.40 MHz
(II) NVIDIA(0): HRes, HSyncStart : 1680, 1728
(II) NVIDIA(0): HSyncEnd, HTotal : 1760, 1840
(II) NVIDIA(0): VRes, VSyncStart : 1050, 1052
(II) NVIDIA(0): VSyncEnd, VTotal : 1058, 1080
(II) NVIDIA(0): H/V Polarity : -/-
(WW) NVIDIA(0): Mode is rejected: VertRefresh (61.1 Hz) out of range
(WW) NVIDIA(0): (0.000-60.000 Hz).

It looks like the EDID caps the VRefresh at 60Hz, even though the only defined native mode requires a 61Hz refresh rate. Try adding the following to the Device section in xorg.conf:
Option "ModeValidation" "NoVertRefreshCheck"
netllama is offline   Reply With Quote
Old 09-01-07, 04:33 PM   #20
gambacherkalben
Registered User
 
Join Date: Aug 2007
Posts: 13
Unhappy Re: Notebook & GeForce 8400M G

Unfortuately, it didn't work. Again, I get the wonderful black screen... ;-(

Any other suggestions? *cry*

Note: Well, I didn't start X in verbose-mode, but perhaps you can see some info either...
Attached Files
File Type: gz nvidia-bug-report.tar.gz (24.9 KB, 103 views)
gambacherkalben is offline   Reply With Quote

Old 09-01-07, 06:27 PM   #21
netllama
NVIDIA Corporation
 
Join Date: Dec 2004
Posts: 8,763
Default Re: Notebook & GeForce 8400M G

You need to provide updated verbose bug reports as long as you'd like further assistance.
netllama is offline   Reply With Quote
Old 09-06-07, 03:44 AM   #22
igorte
Registered User
 
Join Date: Sep 2007
Posts: 6
Default Re: Notebook & GeForce 8400M G

Hi everyone,
I have the same problem as gambacherkalben: nvidia driver on Fujitsu E8410H produces blank screen.
The setup:
- GeForce 8400M G (128MB dedicated)
- Ubuntu Gutsy - AMD64/EM64T
- nvidia driver 100.14.11
- auto-generated (by nvidia-xconfig) xorg.conf (attached). Attempts to tweak it didn't make a difference.
One thing I noticed in the log (attached) is that driver incorrectly recognized video memory size as 512MB instead of 128MB
I tried to set VideoRAM option, but it was ignored. There are no errors in the log that I can see, xstart doesn't fail, but screen remains blank.

Help please!

Thanks

Xorg.0.log.bz2

xorg.conf.bz2
igorte is offline   Reply With Quote
Old 09-06-07, 10:47 AM   #23
netllama
NVIDIA Corporation
 
Join Date: Dec 2004
Posts: 8,763
Default Re: Notebook & GeForce 8400M G

The problem here is that the EDID in your DFP caps the VRefresh range at 60Hz, even though the only defined native mode requires a 61Hz refresh rate:

(--) NVIDIA(0): Valid VRefresh Range : 0 Hz - 60 Hz
(--) NVIDIA(0): EDID maximum pixel clock : 130.0 MHz
(--) NVIDIA(0):
(--) NVIDIA(0): Detailed Timings:
(--) NVIDIA(0): 1680 x 1050 @ 61 Hz
(--) NVIDIA(0): Pixel Clock : 121.40 MHz
(--) NVIDIA(0): HRes, HSyncStart : 1680, 1728
(--) NVIDIA(0): HSyncEnd, HTotal : 1760, 1840
(--) NVIDIA(0): VRes, VSyncStart : 1050, 1052
(--) NVIDIA(0): VSyncEnd, VTotal : 1058, 1080
(--) NVIDIA(0): H/V Polarity : -/-

Try adding the following to the Device section of xorg.conf:
Option "ModeValidation" "NoVertRefreshCheck"
netllama is offline   Reply With Quote
Old 09-06-07, 12:13 PM   #24
zander
NVIDIA Corporation
 
zander's Avatar
 
Join Date: Aug 2002
Posts: 3,740
Default Re: Notebook & GeForce 8400M G

FWIW, in this particular case (the DFP is identified as an Nvidia Default Flat Panel), at least, the EDID is generated incorrectly by the driver; this is a known problem and should be fixed in future driver releases.
zander is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
The GeForce GTX 680M Flagship Notebook GPU Has Landed News Archived News Items 0 06-05-12 03:41 AM
What You Can Expect From GeForce GRID News Archived News Items 0 06-04-12 04:20 PM
Enhance Max Payne 3, Diablo III with GeForce R300 Drivers News Archived News Items 0 05-22-12 06:30 PM
New GPU from Nvidia Announced Today, the GeForce GTX 670 News Archived News Items 0 05-10-12 01:50 PM
Gainward Unleashes the Sexy GeForce GTX 670 Phantom Graphics Card, Also launches the News Archived News Items 0 05-10-12 09:28 AM

All times are GMT -5. The time now is 08:49 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.