Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 11-24-07, 07:58 PM   #25
Zapek
Registered User
 
Join Date: Sep 2007
Posts: 14
Default Re: GeForce Go 7900 GS black flash screen

Thanks! Unfortunately it doesn't work here. One of the differences between our setup is that you have a rev 1 card and I have a rev 0 one, maybe it changes something.
Zapek is offline   Reply With Quote
Old 11-25-07, 01:46 AM   #26
Zapek
Registered User
 
Join Date: Sep 2007
Posts: 14
Default Re: GeForce Go 7900 GS black flash screen

Ok, scratch my previous post. I was wrong.. or at least I wasn't testing properly.

I was adding options in /etc/modprobe.d/options like 'options nvidia ..'. But it seems in ubuntu this doesn't work. They use some weird scripts because of nvidia_old, nvidia and nvidia_new what I just did was the following:

Code:
modprobe --ignore-install nvidia_new NVreg_Mobile=1 NVreg_RegistryDwords="PerfLevelSrc=0x2222"
and then, to check that the parameters were actually processed:
Code:
zapek@bacterion:~$ cat /proc/driver/nvidia/registry | grep Mobile
Mobile: 1
Now I'll let the system run for a few days to see if it fixes it. If so I'll try to investigate why the parameters aren't passed if one uses /etc/modprobe.d/options (I'm pretty sure they are for other drivers though).

BTW, NVreg_SoftEDIDs=0 doesn't seem to work for the latest driver, it tells that the parameter is wrong.
Zapek is offline   Reply With Quote
Old 11-25-07, 06:11 AM   #27
pijalu
Registered User
 
Join Date: Sep 2006
Posts: 20
Talking Re: GeForce Go 7900 GS black flash screen

Quote:
Originally Posted by Zapek
BTW, NVreg_SoftEDIDs=0 doesn't seem to work for the latest driver, it tells that the parameter is wrong.
Shoot me - I sended the /etc/modules.d/nvidia line instead of /etc/modprobe.d/nvidia :-)
[my gentoo install has still some left over and honestly i never remember the correct place...]...
Only difference is the removal of the softedid since as you said, this is refused by the latest driver...
pijalu is offline   Reply With Quote
Old 11-26-07, 07:26 AM   #28
dgrat
Registered User
 
Join Date: Oct 2007
Posts: 16
Default Re: GeForce Go 7900 GS black flash screen

NVreg_RegistryDwords="PerfLevelSrc=0x2222"

seems to help me; but i am using an older driver release (*.19)
dgrat is offline   Reply With Quote
Old 11-26-07, 07:48 PM   #29
Zapek
Registered User
 
Join Date: Sep 2007
Posts: 14
Default Re: GeForce Go 7900 GS black flash screen

Ok it works here. So there's definitely a problem when dynamic clocks are enabled. And the reason this gets noticed more in compiz than eg. plain 2D or games is because clocks vary a lot while using compiz. In 2D it seems to be low clocks everytime and when gaming it seems to be high clocks.

Anyway, so in ubuntu you'd have to add this:
Code:
options nvidia_new NVreg_Mobile=1 NVreg_RegistryDwords="PerfLevelSrc=0x2222"
in /etc/modprobe.d/nvidia-kernel-nkc
Mobile is probably not needed but I like having it to check that the arguments actually worked.

Finally I can use my card! Thanks to everyone involved.
Zapek is offline   Reply With Quote
Old 11-27-07, 08:18 AM   #30
stefan42
Registered User
 
Join Date: Jul 2003
Posts: 51
Default Re: GeForce Go 7900 GS black flash screen

It's the only workaround for me too, but I find it hard to accept that there's neither an official word from nvidia about that parameter nor a fix in the driver. (And of course the workaround leads to increased temperature and shorter battery time.)
stefan42 is offline   Reply With Quote
Old 11-29-07, 07:49 AM   #31
BoardDWorld
Registered User
 
Join Date: Apr 2006
Posts: 30
Default Re: GeForce Go 7900 GS black flash screen

Quote:
Originally Posted by Zapek
Ok it works here. So there's definitely a problem when dynamic clocks are enabled. And the reason this gets noticed more in compiz than eg. plain 2D or games is because clocks vary a lot while using compiz. In 2D it seems to be low clocks everytime and when gaming it seems to be high clocks.

Anyway, so in ubuntu you'd have to add this:
Code:
options nvidia_new NVreg_Mobile=1 NVreg_RegistryDwords="PerfLevelSrc=0x2222"
in /etc/modprobe.d/nvidia-kernel-nkc
Mobile is probably not needed but I like having it to check that the arguments actually worked.

Finally I can use my card! Thanks to everyone involved.
Just amazing! There have been so many threads on this and it has gone on for months, 4 months at minimum! Every time a dev will make a single (useless) comment and then disappear... This is unbelievable considering they designed the driver!

I'll trial this for a 24 hours and report back. Thank you all!
BoardDWorld is offline   Reply With Quote
Old 11-30-07, 10:37 AM   #32
BoardDWorld
Registered User
 
Join Date: Apr 2006
Posts: 30
Default Re: GeForce Go 7900 GS black flash screen

Not a single problem, this is a first for me to be running Linux without this glitch so I'm very happy. Thanks Zapek.

Lastly there is one way to invoke this problem very easily, even with this fix, that's to F11 FireFox into fullscreen. It will flicker in fullscreen mode but F11 back out and it will completely stop. It use to do the same however returning back to normal view and the flicker continued progressively.
BoardDWorld is offline   Reply With Quote

Old 01-07-08, 01:32 AM   #33
BoardDWorld
Registered User
 
Join Date: Apr 2006
Posts: 30
Default Re: GeForce Go 7900 GS black flash screen

This fix no longer works with the current 169.07 driver! Devs, what are your engineers doing!
BoardDWorld is offline   Reply With Quote
Old 01-08-08, 08:01 PM   #34
lamegaptop
Registered User
 
Join Date: Jan 2008
Posts: 2
Default Re: GeForce Go 7900 GS black flash screen

So the new nvidia-settings in the new 169.07 driver has a screen that allows one to monitor the powermizer. Every time the powermizer changes the clock my screen flickers. How do I turn the powermizer off?! better yet how do I control the powermizer to set it off whilst on AC and on low speed whilst on battery?

geforce go 7600 256MB
Debian sid
169.07 driver (this problem was present in the 169.04 driver as well.)

EDIT: OK. the above fix locked my GPU clocks to full. The fix required a reboot in order to take effect. Therefore my hope for manual control is probably a pipe dream. At least my screen does not flicker now.
lamegaptop is offline   Reply With Quote
Old 01-09-08, 06:31 AM   #35
lamegaptop
Registered User
 
Join Date: Jan 2008
Posts: 2
Default Re: GeForce Go 7900 GS black flash screen

I have solved the issue of manually controlling the GPU and Memory speeds on my laptop equipped with a geforce go 7600 card.

Setting the option -

Option "Coolbits" "1"

in the screen section of my /etc/X11/xorg.conf

turns on the overclocking screen in nvidia-settings. One can use this screen to throttle the settings of the GPU and memory clocks to conserve power whilst on battery. No reboot or restart of X required.

WARNING: be careful not to use this to exceed the hardware default settings of your laptop video card!! You will damage components.

Moving the sliders to the left throttles the clock settings. Use the "reset to hardware defaults" button to return the clocks to full whilst on AC or for gaming, etc.

So now my screen does not flicker, thanks to the other fix in this thread, and I can control the clock speeds as needed.

Life is good.
lamegaptop is offline   Reply With Quote
Old 01-11-08, 12:50 PM   #36
fireturd
Registered User
 
Join Date: Jan 2008
Posts: 1
Default Re: GeForce Go 7900 GS black flash screen

Hello:

Just thought that I'd throw in my experience. Installing Ubuntu 7.10 AMD64 SMP with compiz/fusion on a dualcore laptop with 1440X900. Same issues with NVIDIA driver as above. Nothing fixed it - different drivers, used envy to install latest (169.07), etc...

Finally stumbled upon this thread and adding NVreg_RegistryDwords="PerfLevelSrc=0x2222" (as stated above)

finally resolved the issue. I've been flicker free for 30hrs now and completely stable.

Issue seems to affect dual-core and nvidia laptops. I am curious though - when running comiz-fusion benchmark I notice that only one core is maxed out. I am running 7.10 AMD64/SMP. (And can make the other processor spike) so not sure why only one cpu is being utilized.

Cheers.
fireturd is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
Nvidia GeForce 301.42 WHQL drivers DSC NVIDIA Windows Graphics Drivers 5 05-29-12 11:12 PM
Black screen after switching between graphical virtual consoles five times rrr-wtf NVIDIA Linux 1 05-21-12 05:40 PM
New GPU from Nvidia Announced Today, the GeForce GTX 670 News Archived News Items 0 05-10-12 02:50 PM
Gainward Unleashes the Sexy GeForce GTX 670 Phantom Graphics Card, Also launches the News Archived News Items 0 05-10-12 10:28 AM
Black screen and lockup on startx. redmoose NVIDIA Linux 4 09-18-02 12:53 PM

All times are GMT -5. The time now is 06:33 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.