Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 07-27-02, 09:39 PM   #1
thursto77
Guest
 
Posts: n/a
Default syntax error when attempting to compile NVOpenGL SDK

I apologize if this has been addressed before, but I only recently came to this forum and all previous posts had been removed.
Basic information:
Mandrake 8.1 UP
PNY GeForce 4 Ti 4600

I downloaded and installed without problems the kernel drivers and the GLX libraries. I then downloaded the NVSDK and attempted to compile the the OpenGL portion using the included Makefiles. When attempting to do so, any of the source files that include the glh_extensions.h --> glh_genext.h generate a big list of syntax errors. The errors are not very descriptive and look like this:

../../include/glh/glh_genext.h:100: syntax error before ";"
../../include/glh/glh_genext.h:101: syntax error before ";"
.
.
.
../../include/glh/glh_genext.h:500: syntax error before ";"

When I look through the glh_genext.h the lines correspond to the external declerations of the different extension functions which are originally defined in glext.h. What it looks like to me is that the something is not getting defined or is incorrectly defined which is causing they syntax errors when the compiler gets to the glh_genext.h file. I'm sure there is something small that I'm missing but I am at a loss as to what it is. Any assistance would be appreciated, thanks.

-thursto77
thursto77@hotmail.com
  Reply With Quote
Old 07-29-02, 03:24 PM   #2
dgently
Registered User
 
Join Date: Jul 2002
Posts: 7
Default

I also had a lot of problems with it, though i was lucky with a recent cvs version - that is, at least the libs compiled, most demos still didn't compile.
First of all you need at least gcc 3.0.x it seems. I also had to modify the glx_extension.h and an other gl*.h header..
Maybe this post on the opengl.org forum helps you:
http://www.opengl.org/discussion_boa...ML/000680.html

good luck
dgently is offline   Reply With Quote
Old 07-29-02, 05:55 PM   #3
thursto77
Guest
 
Posts: n/a
Smile thanks for the help

Thanks for your help, that other thread was helpful as well in getting the stuff to compile. I understand the mechanics behind why those changes make it work but I don't understand why it was set up the way it was in the first place, was it just a mistake or is it a multi-platform problem? Anyway, thanks again.

-thursto77
  Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 01:08 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.