Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 08-28-07, 12:31 PM   #1
Polaris
Registered User
 
Join Date: Aug 2007
Posts: 6
Default Ubuntu booting to no display

Hi all

After a few days of google searching and looking through here I'm giving up on trying to solve my problem with other people's solutions.

Pretty much, I ran through the instructions listed [url=http://www.nvnews.net/vbulletin/showthread.php?t=72490]here[/url[ and now when I boot Ubuntu I don't get a signal from my card. All the requested files should be attached.

Thanks for your help
Attached Files
File Type: log nvidia-bug-report.log (80.2 KB, 109 views)
File Type: log nvidia-installer.log (2.4 KB, 105 views)
File Type: txt xorg.conf.txt (2.6 KB, 156 views)
File Type: txt xorg.log.txt (20.8 KB, 113 views)
Polaris is offline   Reply With Quote
Old 08-28-07, 12:34 PM   #2
netllama
NVIDIA Corporation
 
Join Date: Dec 2004
Posts: 8,763
Default Re: Ubuntu booting to no display

Does setting NvAGP to 0 in xorg.conf have any impact?
Have you verified that you're using the latest motherboard BIOS?
netllama is offline   Reply With Quote
Old 08-28-07, 01:02 PM   #3
Polaris
Registered User
 
Join Date: Aug 2007
Posts: 6
Default Re: Ubuntu booting to no display

Like so?
Code:
Section "Device"
        Identifier      "Nvidia FX 5200"
        Driver          "nvidia"
        BusID           "PCI:1:0:0"
        NvAGP           0
EndSection
And there are no BIOS updates available from my manufacturer's website.
Polaris is offline   Reply With Quote
Old 08-28-07, 01:07 PM   #4
netllama
NVIDIA Corporation
 
Join Date: Dec 2004
Posts: 8,763
Default Re: Ubuntu booting to no display

No, that is not the correct syntax for adding driver options to xorg.conf. See the driver README.
netllama is offline   Reply With Quote
Old 08-28-07, 01:50 PM   #5
evilghost
Registered User
 
Join Date: Jul 2005
Posts: 3,606
Default Re: Ubuntu booting to no display

Quote:
Originally Posted by Polaris
Like so?
Code:
Section "Device"
        Identifier      "Nvidia FX 5200"
        Driver          "nvidia"
        BusID           "PCI:1:0:0"
        Option          "NvAGP"     "0"
EndSection
evilghost is offline   Reply With Quote
Old 08-28-07, 01:56 PM   #6
netllama
NVIDIA Corporation
 
Join Date: Dec 2004
Posts: 8,763
Default Re: Ubuntu booting to no display

Yes, that looks correct.
netllama is offline   Reply With Quote
Old 08-28-07, 03:47 PM   #7
Polaris
Registered User
 
Join Date: Aug 2007
Posts: 6
Default Re: Ubuntu booting to no display

Wow, that worked!

So now I'm curious why, or if I missed something.
Polaris is offline   Reply With Quote
Old 08-28-07, 03:49 PM   #8
evilghost
Registered User
 
Join Date: Jul 2005
Posts: 3,606
Default Re: Ubuntu booting to no display

Quote:
X Config Options

Option "NvAGP" "integer"

Configure AGP support. Integer argument can be one of:
Value Behavior
0 disable AGP
1 use NVIDIA internal AGP support, if possible
2 use AGPGART, if possible
3 use any AGP support (try AGPGART, then NVIDIA AGP)

Note that NVIDIA internal AGP support cannot work if AGPGART is either statically compiled into your kernel or is built as a module and loaded into your kernel. See Chapter 12, Configuring AGP for details. Default: 3.
Bad motherboard compliance I guess, I'll let Lonni chime in.
evilghost is offline   Reply With Quote

Old 08-28-07, 03:51 PM   #9
netllama
NVIDIA Corporation
 
Join Date: Dec 2004
Posts: 8,763
Default Re: Ubuntu booting to no display

You didn't miss anything. If NvAGP=0 eliminates the problem, then its an AGP driver bug, a BIOS bug, or a hardware problem. None of which are an NVIDIA driver bug. You can try experimenting with different values for NvAGP to see if they help at all.
netllama is offline   Reply With Quote
Old 08-28-07, 03:54 PM   #10
Polaris
Registered User
 
Join Date: Aug 2007
Posts: 6
Default Re: Ubuntu booting to no display

So I pretty much relegated my AGP to PCI?
Polaris is offline   Reply With Quote
Old 08-28-07, 03:59 PM   #11
netllama
NVIDIA Corporation
 
Join Date: Dec 2004
Posts: 8,763
Default Re: Ubuntu booting to no display

Yes, I'm afraid so.
netllama is offline   Reply With Quote
Old 08-28-07, 04:00 PM   #12
evilghost
Registered User
 
Join Date: Jul 2005
Posts: 3,606
Default Re: Ubuntu booting to no display

You could try option 1 but I imagine your distro includes AGPGART so you'd need to disable that. Things don't look very promising if there's no BIOS updates for your MB.
evilghost is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
Russian Masterpieces Put on Display Using NVIDIA GPU Technology News Archived News Items 0 06-25-12 05:10 PM
Precision and purpose: Ubuntu 12.04 and the Unity HUD reviewed News Archived News Items 0 05-28-12 03:20 PM
302.07 (beta) for Linux x86/x86_64 released AaronP NVIDIA Linux 0 05-02-12 10:55 AM
Glx mrbig1344 NVIDIA Linux 7 09-30-02 07:45 AM
Dual Display with main CRT, and secondary TV-out BlackDogg NVIDIA Linux 3 08-10-02 10:52 AM

All times are GMT -5. The time now is 02:30 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.