Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 09-08-07, 08:37 PM   #1
gear2085
Gear2085
 
gear2085's Avatar
 
Join Date: Sep 2007
Location: Colombia
Posts: 3
Send a message via MSN to gear2085 Send a message via Yahoo to gear2085
Exclamation Slow performance 8600GT with Compiz-Fusion on Ubuntu

For start, sorry for my English... I'm Colombian.

My problem it's related with the speed of my card on Linux Ubuntu Feisty Fawn 7.04

I'm have been using the NVIDIA-Linux-x86-100.14.11-pkg1 and follow the rules for
a right installation, include the steps about xorg.conf for Compiz Fusion recently published on this forum.

In some animations, like the Cube, the slow animation is "PASMOSA". I have been found this thread in forums of Ubuntu in spanish, but without solution, this community it is more focus with Nvidia, therefor i hope that the answers will be useful.

I'll post the solution (if i find it, with your help), in mi web site, blog, and Ubuntu Forum Communities in Spanish to help all other people with this problem.

My PC specifications...

MSI K9N Platinum + AMD Atlhon64 X2 4000+ + 1GByte RAM 800Mhz DDR2 +
MSI NX8600GT - 256Mbytes DDR3 - PCI-e

Again sorry for my English and i hope your comments and help.

Thanks... --By GEAR
gear2085 is offline   Reply With Quote
Old 09-10-07, 06:05 PM   #2
DeepThought
Registered User
 
Join Date: Sep 2007
Posts: 14
Default Re: Slow performance 8600GT with Compiz-Fusion on Ubuntu

I seem to have the same problem. I have a GeForce 8600M GT running Ubuntu Gutsy, and when I turn Compiz Fusion on it works smooth, but suddenly (often when rotating the cube) the FPS drops to <7. When I stop rotating the cube the FPS often goes back to 50-70, but sometimes (randomly, it seems) the FPS just stays at about 7.

It's definately a bug, but I can't figure out what software is responsible. I know that it's not because the graphics card is to low-end, because from time to time the FPS is stable at 70+ no matter how much I paint fire and flip the cube..

I will (maybe) try a newer version of Compiz Fusion, just to determine if that's the problem. I also have a suspicion that it's my xorg.conf.. hard to tell, thou.

My computer is a Zepto Znote 6224W btw.
DeepThought is offline   Reply With Quote
Old 09-10-07, 08:21 PM   #3
gear2085
Gear2085
 
gear2085's Avatar
 
Join Date: Sep 2007
Location: Colombia
Posts: 3
Send a message via MSN to gear2085 Send a message via Yahoo to gear2085
Default Re: Slow performance 8600GT with Compiz-Fusion on Ubuntu

Again sorry for my English.

Thanks, at last somebody answer for my call...


You'll see, the problem with your theory is that i have added Treviño's repositories, upgraded almost daily, but nevertheless i have serious slow performance on my system, you have post in another forum (ANGLO) this trouble, someplace where i can find some info?...

I'm gonna put in this place, some sites on Spanish where it discuss this problem.

--By GEAR
gear2085 is offline   Reply With Quote
Old 09-13-07, 02:18 AM   #4
DeepThought
Registered User
 
Join Date: Sep 2007
Posts: 14
Default Re: Slow performance 8600GT with Compiz-Fusion on Ubuntu

You're probably right. I updated my compiz-version and the problem still exists. It works great for some minute, then suddenly the fps drops to 30 and after that a steady decrease towards almost 5 fps.

I have noticed that the process compiz.real seems to use more than 60% of the CPU when this happens.

Hopefully there will be a solution to this problem some day soon. Does anyone know when new NVIDIA-Linux-drives will be released, btw?
DeepThought is offline   Reply With Quote
Old 09-13-07, 09:24 PM   #5
Alejandro Nova
Registered User
 
Join Date: Sep 2006
Posts: 26
Default Re: Slow performance 8600GT with Compiz-Fusion on Ubuntu

Right click in the Fusion icon, and, in "Compiz Options" DESELECT "Indirect Rendering" AND SELECT "Loose Bindings". If I configure Compiz Fusion that way, CPU usage never goes beyond 25% here (Sempron 2500, GF FX 5500, I'm sure that your video card and processor is better than that), and I'm getting about 50, 60 FPS all the time. Beryl autodetected that, but Compiz does not. (Maybe it's because of nVidia's implementation of 3D indirect acceleration: it is propietary, it is not AIGLX)

(Sólo en caso de que no me entiendan, en el icono de arriba de la flechita hacia la diagonal superior izquierda, que es el icono de Compiz Fusion, desactiven "Indirect Rendering" y activen "Loose Bindings" en donde dice "Compiz Options").
Alejandro Nova is offline   Reply With Quote
Old 09-14-07, 12:15 PM   #6
DeepThought
Registered User
 
Join Date: Sep 2007
Posts: 14
Default Re: Slow performance 8600GT with Compiz-Fusion on Ubuntu

Hello Alejandro Nova!

Thanks for the tip! It seems like it has helped at least a bit (but my FPS is now 250 ). Unfortunately I have no Compiz-Fusion-icon - probably because I'm using Xubuntu. But I can fix that on compiz startup instead..

By the way, it seems like the Benchmark-plugin is one of the things that makes the speed drop.. wierd, huh?

Unfortunately I have only tested for some minutes now, but I will do some more extensive testing when I have got the time.

Thanks!
DeepThought is offline   Reply With Quote
Old 09-15-07, 12:40 AM   #7
gear2085
Gear2085
 
gear2085's Avatar
 
Join Date: Sep 2007
Location: Colombia
Posts: 3
Send a message via MSN to gear2085 Send a message via Yahoo to gear2085
Thumbs up Re: Slow performance 8600GT with Compiz-Fusion on Ubuntu

Muchas gracias Alejandro, llevaba ya bastante tiempo tratando de encontrar solución a este problema y no lo había logrado, en ningún foro pude encontrar ayuda, haré re circular tu respuesta para que otras personas que he encontrado con la misma duda, puedan resolver su problema.

Si tienes un blog o algo así, me puedes escribir a mi correo para ligarlo al mio.

De nuevo muchas gracias, un gran aporte de verdad.

--By GEAR
gear2085 is offline   Reply With Quote
Old 11-13-07, 03:04 PM   #8
Sblantipodi
Registered User
 
Sblantipodi's Avatar
 
Join Date: Apr 2003
Location: Italy
Posts: 154
Default Re: Slow performance 8600GT with Compiz-Fusion on Ubuntu

Quote:
Originally Posted by DeepThought
Hello Alejandro Nova!

Thanks for the tip! It seems like it has helped at least a bit (but my FPS is now 250 ). Unfortunately I have no Compiz-Fusion-icon - probably because I'm using Xubuntu. But I can fix that on compiz startup instead..

By the way, it seems like the Benchmark-plugin is one of the things that makes the speed drop.. wierd, huh?

Unfortunately I have only tested for some minutes now, but I will do some more extensive testing when I have got the time.

Thanks!
I haven't an icon too.
How have you disabled indirect rendering? Please help...
__________________
FPC Bench, a good java benchmark for mobile phones and PDA.
http://www.dpsoftware.org
Sblantipodi is offline   Reply With Quote

Old 11-13-07, 04:24 PM   #9
DeepThought
Registered User
 
Join Date: Sep 2007
Posts: 14
Default Re: Slow performance 8600GT with Compiz-Fusion on Ubuntu

You can install Compiz Fusion Icon. I don't know if there's any "nice" place to get it for Ubuntu-users, but check those links:
http://tombuntu.com/index.php/2007/0...ion-tray-icon/
http://wiki.opencompositing.org/CompizFusionIcon

Otherwise you can use the flag --indirect-rendering and perhaps some more flag when you start compiz. Please refer to the manual (man compiz) for more info. I'm sorry I can't remember exacly how I did it (since I later started to use the C-F Icon, and then finally stopped using C-F).
DeepThought is offline   Reply With Quote
Old 11-13-07, 06:11 PM   #10
Sblantipodi
Registered User
 
Sblantipodi's Avatar
 
Join Date: Apr 2003
Location: Italy
Posts: 154
Default Re: Slow performance 8600GT with Compiz-Fusion on Ubuntu

Quote:
Originally Posted by DeepThought
You can install Compiz Fusion Icon. I don't know if there's any "nice" place to get it for Ubuntu-users, but check those links:
http://tombuntu.com/index.php/2007/0...ion-tray-icon/
http://wiki.opencompositing.org/CompizFusionIcon

Otherwise you can use the flag --indirect-rendering and perhaps some more flag when you start compiz. Please refer to the manual (man compiz) for more info. I'm sorry I can't remember exacly how I did it (since I later started to use the C-F Icon, and then finally stopped using C-F).
many many thanks, I solved with --loose-bindings...
I switched from 60FPS to 800FPS :O
__________________
FPC Bench, a good java benchmark for mobile phones and PDA.
http://www.dpsoftware.org
Sblantipodi is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
Unity 5.12 Fixes Ubuntu OpenGL Performance Problems News Archived News Items 0 06-11-12 02:20 PM
Sluggish performance 8400M GS Ubuntu 12.04 Unity 3D bgneal NVIDIA Linux 1 05-24-12 07:16 PM
My UT2003 Tweak Guide DXnfiniteFX Gaming Central 48 10-31-02 12:59 AM

All times are GMT -5. The time now is 02:09 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright ©1998 - 2014, nV News.