Go Back   nV News Forums > Linux Support Forums > NVIDIA FreeBSD

Newegg Daily Deals

Reply
 
Thread Tools
Old 05-18-07, 03:41 PM   #1
usleepless
Registered User
 
Join Date: May 2007
Posts: 3
Default Composite and DamageEvents

Dear All,

after getting fed up with my ATI9250 cards performance with Composite and GLX in general, i decided to try Nvidia.

got a XFX5200, installed the FreeBSD driver 9755 and stuff was much much better. got Composite running at a decent rate. got GLX running much better, enabling TwinView was a breeze.

but, there seems to be an issue with Composite and DamageEvents.

1. if i disable Composite, i get 1950 fps out of glxgears.
2. if i enable Composite and enable DamageEvents only the first frame seems to be rendered and glxgears hangs ( so does googleearth ). so it seemed: glxgears is actually rendering at 0.5 fps.
3. if i enable Composite and disable DamageEvents, glxgears gets about 500fps, but is is choppy about once a second.

this was first tested on 6.9.0, and later on 7.2. the results seem identical.

so, are Composite and DamageEvents mutually exclusive? that's odd considering the description of DamageEvents.

furthermore, the Makefile could use:

.if ${X_WINDOW_SYSTEM} == "xorg" && version > 7.0??
sed -i -e 's|lib/modules|lib/xorg/modules|' \
../x11/driver/Makefile \
../x11/extension/Makefile \
../x11/lib/Makefile
.endif

then i went on and tried to install the beta x86-100.14.03, to see if that would help with the DamageEvents:

problem 1:
the Linux-pkg0-version is not downloadable from the specified link. you end up with the pkg1-version.
problem 2:
although i downloaded the pkg0 version and pkg1 version, neither would be accepted by the add_linux_libs.sh script: version mismatch. why make us testers jump through these hoops? is it too much trouble to upload a complete .tar.gz?
problem 3:
after i removed the version-check from the script and did build the driver, it crashed.

this is all on 6.2 BTW. is it very hard to rebuild the driver for 6.2, eliminating the need for compat5x?

regards,

usleep
usleepless is offline   Reply With Quote
Old 05-21-07, 09:11 PM   #2
jbsnyder
Registered User
 
Join Date: May 2007
Posts: 10
Default Re: Composite and DamageEvents

Same deal here. Xorg 7.2 (from the latest ports commit). With composite enabled (and a composite-utilizing WM, ie Compiz), I get GL apps doing a poor rendering of the first frame, and then nothing after that. Compiz itself works fine, and with all that disabled, GL apps work just fine. At the moment though, they're like oil and water.

I've seen reports of others running into this same issue over in freebsd-ports who have upgraded xorg and are attempting to run composite-utilizing applications.

On a side note, I'd like to thank the folks at nVIDIA for making this driver available in the first place. First class performance on a first class (though much smaller user base than your other supported platforms) operating system is awesome :-)
jbsnyder is offline   Reply With Quote
Old 06-02-07, 02:25 PM   #3
jbsnyder
Registered User
 
Join Date: May 2007
Posts: 10
Default Re: Composite and DamageEvents

Any updates on this matter? I'd be happy to hear that at least someone is aware of the issue/can reproduce it
jbsnyder is offline   Reply With Quote
Old 06-03-07, 03:43 PM   #4
zander
NVIDIA Corporation
 
zander's Avatar
 
Join Date: Aug 2002
Posts: 3,740
Default Re: Composite and DamageEvents

Could you generate and attach nvidia-bug-report.log (via nvidia-bug-report.sh) files against the 100.14.06 FreeBSD graphics driver release? Also, can you describe how you installed Xorg 7.x and compiz on FreeBSD 6.2?
zander is offline   Reply With Quote
Old 06-03-07, 04:38 PM   #5
jbsnyder
Registered User
 
Join Date: May 2007
Posts: 10
Default Re: Composite and DamageEvents

I've emailed the address referenced in nvidia-bug-report.sh.

2 other minor things of note when I tried installing the beta drivers:

1. with an X11BASE adjusted to /usr/local as things are now with the new Xorg installs, I found I needed to adjust LIBDIR for driver extension and lib:

LIBDIR= ${X11BASE}/lib/xorg/modules

2. As I believe is noted in the instructions, nvidia-settings needs to be reinstalled. What was a bit troublesome about this was that I had a working version installed from ports (nvidia-settings 1.0), and this ended up overwriting that, requiring me to reinstall nvidia-settings from ports.

Best wishes and thanks for the drivers. I'm sure I speak for anyone using these drivers on FreeBSD when I say thanks a million. I'm guessing NVIDIA has no commercial interest in the platform (aside from perhaps helping in make the drivers core more solid across all platforms), and so we really appreciate the attention to looking into bugs :-)
jbsnyder is offline   Reply With Quote
Old 06-03-07, 04:41 PM   #6
jbsnyder
Registered User
 
Join Date: May 2007
Posts: 10
Default Re: Composite and DamageEvents

For posterity sake, I've put the email over at pastebin as well:

http://www.pastebin.ca/534755
jbsnyder is offline   Reply With Quote
Old 06-10-07, 05:21 AM   #7
jstocker
Registered User
 
Join Date: Jun 2007
Posts: 3
Default Re: Composite and DamageEvents

This bug also happens using good old Enlightenment 0.16.8 (MiddleMouseButton -> Settings -> Composite Settings) as window manager with old and newest driver 100.14.09 on XOrg 6.9 and 7.2

Driver: nvidia-driver-100.14.09
Card: <GeForce FX Go5200 32M/64M> mem 0xc8000000-0xc8ffffff,0xd8000000-0xdfffffff irq 11 at device 0.0 on pci1
WindowManager: enlightenment-0.16.8.6_1
XOrg: 7.2
jstocker is offline   Reply With Quote
Old 06-15-07, 08:00 PM   #8
zander
NVIDIA Corporation
 
zander's Avatar
 
Join Date: Aug 2002
Posts: 3,740
Default Re: Composite and DamageEvents

Thank you for the detailed report, I was able to reproduce the problem on FreeBSD 6.2. We'll investigate.
zander is offline   Reply With Quote

Old 06-24-07, 11:40 AM   #9
zander
NVIDIA Corporation
 
zander's Avatar
 
Join Date: Aug 2002
Posts: 3,740
Default Re: Composite and DamageEvents

I forgot to post an update earlier: this problem is now understood and should be fixed in a future driver release.
zander is offline   Reply With Quote
Old 08-28-07, 12:55 AM   #10
jstocker
Registered User
 
Join Date: Jun 2007
Posts: 3
Default Re: Composite and DamageEvents

@Zander: Any progress in solving this problem?
jstocker is offline   Reply With Quote
Old 09-04-07, 11:55 AM   #11
zander
NVIDIA Corporation
 
zander's Avatar
 
Join Date: Aug 2002
Posts: 3,740
Default Re: Composite and DamageEvents

@zander: it should be resolved in the next 100.14.xx driver release.
zander is offline   Reply With Quote
Old 10-10-07, 08:40 AM   #12
frase
Registered User
 
Join Date: Apr 2007
Posts: 15
Default Re: Composite and DamageEvents

unfortunately, the issue seems to still be there in 100.14.19

any news?

frase
frase is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 02:41 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.