Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 09-18-07, 08:35 PM   #1
MQMan
Registered User
 
Join Date: Jul 2005
Posts: 15
Default 100.14.11 Terminals go double spaced on exit from KDE

I've just installed the 100.14.11 drives on a new Slack 12 system, with a GeForce 6600 based card, on an nForce 2200/2050 based mobo.

Everything installed OK, and I was able to start KDE. But, on exiting from KDE, all the terminals are now double spaces, not just the one I ran startx from, which means I can only see the top 25 lines, instead of the normal 44.

How can I stop this happening, or in the short term, recover my displays without having to re-boot.

Cheers.
MQMan is offline   Reply With Quote
Old 09-18-07, 08:38 PM   #2
netllama
NVIDIA Corporation
 
Join Date: Dec 2004
Posts: 8,763
Default Re: 100.14.11 Terminals go double spaced on exit from KDE

If this problem persists with 100.14.19, please see the forum sticky posts.
netllama is offline   Reply With Quote
Old 09-19-07, 11:48 AM   #3
MQMan
Registered User
 
Join Date: Jul 2005
Posts: 15
Default Re: 100.14.11 Terminals go double spaced on exit from KDE

OK, tried with the 100.14.19 drivers, and have exactly the same issue.

I found that I can get the terminals back to "normal" by running /etc/rc.d/rc.font, which re-issues my setfont command.

Here's the output requested:

Cheers.
Attached Files
File Type: zip nvidia-bug-report.zip (34.2 KB, 102 views)
MQMan is offline   Reply With Quote
Old 09-19-07, 11:53 AM   #4
netllama
NVIDIA Corporation
 
Join Date: Dec 2004
Posts: 8,763
Default Re: 100.14.11 Terminals go double spaced on exit from KDE

Does this problem reproduce with the 'nv' or 'vesa' X drivers?
netllama is offline   Reply With Quote
Old 09-19-07, 12:01 PM   #5
MQMan
Registered User
 
Join Date: Jul 2005
Posts: 15
Default Re: 100.14.11 Terminals go double spaced on exit from KDE

No. The "nv" drivers work correctly.

Cheers.
MQMan is offline   Reply With Quote
Old 09-20-07, 04:06 AM   #6
RobotMarvin
Registered User
 
Join Date: Oct 2006
Location: Germany
Posts: 77
Default Re: 100.14.11 Terminals go double spaced on exit from KDE

Unfortunately I cannot confirm that... the nv driver from the Xorg 7.3 release causes exactly the same problem.

I am very likely suffering from the same problem for at least two month now and haven't found a solution. Switching from X to the VT, the console font is reset to something 80x25 non-latin1, no matter what original font I had setup. This usually puts the cursor off screen. Setting the font again manually works till the next switch. This is with no framebuffer or anything else fancy.

Depending on what font I had tried, btw, I have also seen double spaced VTs when I switched from X. So this fits.
RobotMarvin is offline   Reply With Quote
Old 09-20-07, 02:35 PM   #7
MQMan
Registered User
 
Join Date: Jul 2005
Posts: 15
Default Re: 100.14.11 Terminals go double spaced on exit from KDE

I'm not sure of the Xorg version that's shipped with Slack 12, but nv 2.0.96 on xorg-server 1.3.0 didn't exhibit the problems.

Cheers.
MQMan is offline   Reply With Quote
Old 12-24-07, 06:41 PM   #8
MQMan
Registered User
 
Join Date: Jul 2005
Posts: 15
Default Re: 100.14.11 Terminals go double spaced on exit from KDE

Just tried the latest 169.07 driver. No difference. I still get double spaced output.

Cheers.
MQMan is offline   Reply With Quote

Old 12-25-07, 12:52 PM   #9
evil_core
Registered User
 
Join Date: Sep 2007
Posts: 27
Default Re: 100.14.11 Terminals go double spaced on exit from KDE

I dont know if it can be related, i use Gnome usually, but maybe its some optimizations in konsole that use Xv or sth like it, because i have doubled in height(or more precisely halfed in hsize) Xv using applications like totem or xine when i run them in 1024x768. I dont have such problem when i run them when screen size is set to 2048x768, and when they are running calling xrandr -s 1024x768, doesnt change anything. Its new xorg and twinview/xinerama related, and o dont have this problem in mplayer using xv or any opengl application.
evil_core is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 10:07 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.