Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 09-26-07, 04:58 AM   #1
sensovision
Proud user of Debian OS
 
sensovision's Avatar
 
Join Date: Jun 2004
Location: Ukraine
Posts: 26
Send a message via ICQ to sensovision
Unhappy Can't get AGP working

Hi!
I've got a problem, when I'm using legacy driver my PC hangs up during starting of X server. I've solved it by "NvAGP" "0".
But I'd like to make AGP working if possible.

Previously when I had Windows on my PC I can boot into Windows first and later I start with AGP enabled, but now I have only Linux installed.

Anybody could help me address this issue?
Attached Files
File Type: log nvidia-bug-report.log (101.2 KB, 82 views)
sensovision is offline   Reply With Quote
Old 09-26-07, 10:06 AM   #2
netllama
NVIDIA Corporation
 
Join Date: Dec 2004
Posts: 8,763
Default Re: Can't get AGP working

If you need to disable AGP in order to use X, then the problem is any combination of the following:
0) Motherboard BIOS bug
1) AGP driver bug
2) Hardware problem

I'm afraid that no one here can fix any of those for you.
netllama is offline   Reply With Quote
Old 09-26-07, 12:49 PM   #3
sensovision
Proud user of Debian OS
 
sensovision's Avatar
 
Join Date: Jun 2004
Location: Ukraine
Posts: 26
Send a message via ICQ to sensovision
Default Re: Can't get AGP working

Hi netllama and thank you for wish to help!
Quote:
0) Motherboard BIOS bug
yeah I think it's possible, but from other side why Windows is working and have AGP enabled without issue, and it also make AGP work on Linux... Any idea?

Quote:
1) AGP driver bug
I guess not, since not Nvidia driver nor driver amd64_agp shipped with kernel are working and I wasn't able to make NVidia AGP working even with Windows reboot.

Quote:
2) Hardware problem
I've test 3 cards on this motherboard and all of them are failed in same way, they was working under Windows but not under Linux with AGP enabled, so I guess it's not hardware since it wouldn't work in Windows too, or I'm wrong?

Quote:
I'm afraid that no one here can fix any of those for you.
I understand this and trying to sell my motherboard+CPU+RAM to buy new one but doesn't have luck yet.

Can you tell how card initialization process under Linux is actually differ from Windows, as after boot to Windows I was able to use AGP until complete power off... any idea what could it be?
sensovision is offline   Reply With Quote
Old 09-26-07, 12:53 PM   #4
netllama
NVIDIA Corporation
 
Join Date: Dec 2004
Posts: 8,763
Default Re: Can't get AGP working

I can't say with any certainty why it works fine in Windows. Perhaps the AGP driver has a workaround for a BIOS or hardware issue? Perhaps the Linux AGP driver has a bug?
netllama is offline   Reply With Quote
Old 09-26-07, 01:31 PM   #5
sensovision
Proud user of Debian OS
 
sensovision's Avatar
 
Join Date: Jun 2004
Location: Ukraine
Posts: 26
Send a message via ICQ to sensovision
Default Re: Can't get AGP working

Quote:
I can't say with any certainty why it works fine in Windows. Perhaps the AGP driver has a workaround for a BIOS or hardware issue? Perhaps the Linux AGP driver has a bug?
I see. I was hoping that you may have such kind of information so I may start looking in right direction.

BTW the reason I've asked this question is that I have possibility to upgrade to other VIA based motherboard(no NForce boards for 754 socket is available unfortunately), but I'm afraid that this problem would re-occur on it as well and I just waste money again(can't take it for testing).

Is there any tests that I could perform in order to find out where the problem is?
sensovision is offline   Reply With Quote
Old 09-26-07, 01:44 PM   #6
netllama
NVIDIA Corporation
 
Join Date: Dec 2004
Posts: 8,763
Default Re: Can't get AGP working

I suppose you could (re)build the kernel agp driver with debug symbols, but unless you're well versed in kernel debugging (and even if you are), you might not find anything obviously wrong.
netllama is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
Gentoo and agp trouble john36 NVIDIA Linux 2 09-12-02 10:36 PM
agp 440bx/zx tntultar32 t00bad NVIDIA Linux 1 09-11-02 02:46 PM
How much heat can a GeForce4 Ti 4600 handle? Velkator NVIDIA GeForce 7, 8, And 9 Series 4 09-03-02 04:41 PM
X freezes when agp 4x is enabled jinksed NVIDIA Linux 1 08-07-02 04:56 PM
Will AGP 8X increase performance over AGP 4X? sancheuz NVIDIA GeForce 7, 8, And 9 Series 10 07-29-02 08:37 PM

All times are GMT -5. The time now is 01:16 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.