Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 09-30-07, 05:14 PM   #1
Bernd Stuht
Registered User
 
Join Date: Sep 2007
Posts: 19
Default White Screen with Compiz

Hello,

i have installed Suse 10.3RC1 on my System.
Installed the actual NVIDIA Drivers for 3D, Compiz in the last Versions.

When i start KDE i get a White Screen, this only happens when KDE
starts compiz automatically.

I have renamed compiz to compiz.exe so the System can't start compiz
because it does not find it ;-)

When xgl is active, kde is up - i have no window-decorator.

Now i can start compiz(.exe) and the kde-window-decorator and it
works !

What is the Error ?

System: C2D, 4GB Ram, nvidia8600gts

Bernd
Bernd Stuht is offline   Reply With Quote
Old 10-02-07, 12:56 AM   #2
Bernd Stuht
Registered User
 
Join Date: Sep 2007
Posts: 19
Default Re: White Screen with Compiz

More Info: Only killing of the task compiz and restart ist while KDE is running
solves the Problem - an delay while loading of compiz does not work.

Because the Keyboardinput does not work with killed Compiz i have used
the execute Command of the kde Menu, you should executed compiz with this
before - so you can select the command with the Mouse.

I have done this - and Compiz WORKs !

But starting is a bit complicated.... .

Also - some People wrote that the Vesions of xgl and nvidiaxgl Librarys are the
Reason for this Bug - because of the Fact that it works with restart - i think it is
an other Problem !

Bernd
Bernd Stuht is offline   Reply With Quote
Old 10-03-07, 01:43 AM   #3
Bernd Stuht
Registered User
 
Join Date: Sep 2007
Posts: 19
Default Re: White Screen with Compiz

More Info:

The gnome-xgl-switch whitch should be used to activate xgl for Compiz isnīt needed
for an nvidia Installation - this Script sets the Displaymanager in /etc/sysconfig/displaymanger to xgl - this worked on my old Laptop ( ATI M6LYGfx )
an my older 32Bit AthlonPC with NV6200A GFX.

The White Screen Bug happens now on my new System - using the same Way to ativate
Compiz - i found out that an killing of compiz while running KDE with "White Screen"
( on console as root ( killall compiz ) ) brings you back your KDE-Screen.
But no Windowgadgets, and no Keyboardinputs are possible.
Starting compiz on KDE ( in a way using the Mouse ) solves the Problem.
-> Compiz works after this Procedure - but every Restart brings you back the White
Screen ( again killall compiz - and so on ).
A script thatīs automatically kills compiz slighly some seconds after KDE is up
worked too for me - an Gadget on KDE starts Compiz - better Solution... .
Insertting of automatically starting compiz in this script does not work 100%.

Now - inspirated by "Lord Mephisto" from the exellent Gigabyteforum i found out
that XGL as Displaymanager isnīt needed by Compiz ( Written above - i knew )

Using of Xorg instead of Xgl solves the Problem too !
But glxgears is slower on Xorg - but works stable ( 8000-10000fps )
glxgears on xgl often crashes x completely, but when running about 19000fps.

This could be an optimizing Problem of my xorg.conf - i think so.

Hardware: C2D 2666 @ 2666Mhz - nv8600gts256DDR3
System : Suse 10.3RC1 nvdriver V100.14.19 Kernel 2.6.22.5-9 (?) actual...
( System is down - working with my old Laptop - Coffee in the Morning in the Livingroom ;-) )

Bernd
Bernd Stuht is offline   Reply With Quote
Old 10-30-07, 12:34 AM   #4
Bernd Stuht
Registered User
 
Join Date: Sep 2007
Posts: 19
Default Re: White Screen with Compiz

In the new Beta Release of the nvidia-Driver ( 100.14.23 ) and with the newer
Version of Compiz ( 0.6.2 ) the Problem seems to be solved.

Some Blankermodules still crashes the System - why ? - i do not knew.
( KDE Interaccurate for Example )

Also ( donīt seen bevore )

kwin --replace

stops compiz and you have got a normal KDE incl. Window Gadgets.

Greetings - Bernd

Problem solved - Threat could be closed
Bernd Stuht is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
[Bug Report] Xid error after resume with 307.02, and compiz stops working. John K. NVIDIA Linux 0 05-09-12 02:42 PM
Toshiba Sat 1950 screen setup beaulieu NVIDIA Linux 7 06-13-03 03:17 PM
Redhat 8.0 NVIDIA works - INSTRUCTIONS STEEL1 NVIDIA Linux 267 04-15-03 06:48 PM
TV-out - only white blue screen on TV zefme NVIDIA Linux 13 08-19-02 10:46 PM

All times are GMT -5. The time now is 08:51 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright Đ1998 - 2014, nV News.