Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 07-28-02, 05:48 PM   #1
-=Taint=-
Guest
 
Posts: n/a
Unhappy SuSe 8.0 Not very happy!

Hi Guys, I'm using a gf4 ti 4600, asus a7m266, tbird1.4. My problem is that no matter how I install the nvidia drivers, i encounter the same err msg. I've reinstalled linux 4 times, using gnome or kde, and used both YaST, and manual. At least I can be proud that both my linux and me are capable of being consistent?

Th error msg i see in XF86Config (not exact, cuz i'm in windoze) is something like
(EE) Failed to allocate dma push buffer

That's all the error says. No AGP error, no Screen error.

Also, my most recent time, I YaST'd the files in, and X booted just fine, it was when I edited the XF86Config file to read
Load "glx" and Driver "nvidia"

that things got screwy. I am positive the files are properly installed, rpm tells me so. Also, I misspelled nvidia -> nvdia, and the XF86Config said "Hey I can't find that." When spelled properly, it is found. Please someone, know what I'm talking about, I'm dying to see what havoc this card can wreak in linux...


-=Taint=-

PS, if this is totally not helpful, I'm sure there's a way I could get that XF86Config out of unhappy territory and into this board...
  Reply With Quote
Old 08-03-02, 01:57 PM   #2
Hoggie
Guest
 
Posts: n/a
Default

I have exactly the same error as yourself, but I'm running a GEForce 2 MX 400 on a PIII 1 Ghz machine with a fresh FTP install of SuSE 8.0 + the updated drivers from NVidia.

Anybody got a clue?
  Reply With Quote
Old 08-03-02, 06:10 PM   #3
vforge37
Guest
 
Posts: n/a
Default Try this

When you get booted back into the console, type in, as root:

modprobe NVdriver

see if it lets you load the nvidia driver or not.

If it works, then log back into your user account and type in:

startx

And see if it gives you any more details. Then submit your XF86Config-4 file onto this forum, and we'll see what's going on with that sucker.

P.S. Could you let me know which drivers you're running? I.E. are you running the Suse precompiled binary drivers from nvidia's website, or the .tar.gz files?

-Fred Hernandez
  Reply With Quote
Old 08-04-02, 10:05 AM   #4
megajocke
Guest
 
Posts: n/a
Default

I got it to work when i recompiled the kernel module. Read the README file inside the directory where the sources got installed. I think it was something like /usr/src/[kernel-drivers or something like that]/[NV-something].
  Reply With Quote
Old 08-04-02, 11:06 AM   #5
Hoggie
Guest
 
Posts: n/a
Default Re: Try this

Quote:
Originally posted by vforge37
When you get booted back into the console, type in, as root:

modprobe NVdriver

see if it lets you load the nvidia driver or not.

If it works, then log back into your user account and type in:

startx
This is somewhat different. It starts up and then fails with a "connection reset by peer" (error 104). It leaves me with a blank screen.

Quote:

And see if it gives you any more details. Then submit your XF86Config-4 file onto this forum, and we'll see what's going on with that sucker.
File attached.

Quote:

P.S. Could you let me know which drivers you're running? I.E. are you running the Suse precompiled binary drivers from nvidia's website, or the .tar.gz files?
I've tried the update from SuSE and the binary RPMs from the nvidia site. The files are the same for both the nvidia site and the SuSE automatic update download. I manually hacked my config first time (installing from the nVidia site) and with the SuSE update , sax did the work. Both with the same results.

The files are version 1.0-2960.

I kinda find this strange since I have an athlon at home with a similar card, but older nVidia drivers on SuSE 7.3 and have never had any problems.
Attached Files
File Type: txt xf86config.txt (3.8 KB, 263 views)
  Reply With Quote
Old 08-04-02, 11:27 AM   #6
ziphnor
Registered User
 
Join Date: Aug 2002
Posts: 14
Default

Im having the exact same problem, just installed Suse 8.0, downloaded the 2 rpms, installed the kernel driver, tried the GLX driver , but one was already there so removed it with rpm -e and then it installed okay. I changed the settings in XF86Config( i dont have a -4 one and the XFree86 log uses XF86Config)
changing Driver "nv" to Driver "nvidia" and adding Load "glx" under modules. This resulted in a blackscreen but no errors in the log, except a warning about EDID, i added Option "IgnoreEDID" and then the log showed the same error as is mentioned above, regarding allocation of "DMA push buffer". Arghh.. big time bummer

I could use some help, as if that isnt obvious
ziphnor is offline   Reply With Quote
Old 08-04-02, 11:51 PM   #7
vforge37
Guest
 
Posts: n/a
Default Ok try this...

Ok, I'm just comparing my XF86Config file to yours and I see a couple of differences. I don't know if any of this could help, but I guess it couldn't hurt.

First, go down to the modules area and comment out these lines by adding a # in front of them

#load "extmod"
#load "speedo"

And add into the modules section

load "v4l" // This does really cool stuff like window-only redraws when you move a xine video window around. Highly recommended.

Then change your

Options "dpms"

line to look like this:

Options "DPMS" "on"

After all this see if this makes any difference... if it doesn't...

I searched google groups to see if I could find some help for you and it turns out that maybe you're booting with a Virtual Frame Buffer device, which is kind of like a video driver, and maybe this driver is sticking around and screwing with X... This is a longshot, but try this...

1) First, as root, open up lilo.conf in your favorite editor.

2) look for a line that says

vga=*something*

There's probably several of these lines... under different "images."

If it exists, then you're using a virtual frame buffer device.

3) What you want to do is disable the virtual frame buffer devices, so find the "label" or section which describes the kernel that you boot into at startup. And comment out that vga line like so...

#vga=*something*

Make sure to only comment out the vga line under the label which you use... You want to be sure to have other *unchanged* options to boot into in case this doesn't work.

4) As root, at the command prompt, type in...

/sbin/lilo

This resets lilo so that your settings have been changed and you won't be booting into a virtual frame buffer device any more. Be warned though, that if something goes wrong your system can become unbootable... if you're unsure of what you're doing, post up your lilo.conf file and I can take a look at it.

I hope this helps, please let us all know if this works. And sorry if I went into a lot of details, I'm just not sure with how familiar you are with linux.

Good Luck,

Fred Hernandez
  Reply With Quote
Old 08-05-02, 04:32 AM   #8
ziphnor
Registered User
 
Join Date: Aug 2002
Posts: 14
Default

Im actually a little bit reluctant to try and install the nvidia drivers again, i just reinstalled suse
I added another boot option though, and removed the vga option from it.
This makes the bootup happen in standard text mode instead of the cool 1024x768 green/black display.

I also made the other config changes you mentioned, so now all i should have to do is install the drivers themselves....
Is there a way to uninstall them from runlevel 3 and restore the old drivers easily?

Btw: this time i didnt install the old 0.8 kernel and glx driver that comes with suse(at least i deselected those packages).
ziphnor is offline   Reply With Quote

Old 08-05-02, 05:35 AM   #9
Hoggie
Guest
 
Posts: n/a
Default

Thanks for you advice vforge37. I tried everything as suggested, but it did not seem to make a difference. I took the advice of megajocke and tried the source RPMS. Bullseye! No problems at all and the 3D stuff works.

It is noteworthy that the nVidia Source GLX rpm picked up the existance of the Mesa libGL and renamed it.

Maybe if one of the nVidia or SuSE bods are reading this, they could make the adjustment to the binary RPMs.

Cheers, All.
  Reply With Quote
Old 08-05-02, 09:01 AM   #10
vforge37
Guest
 
Posts: n/a
Default Awesome :)

Hey man, that's awesome that you got it to work. I didn't think to have you recompile the drivers since you have a clean install. Oh well, live and learn not to trust binary packages

Hey Ziphnor, have you tried recompiling the drivers like Hoggie?

If you need any help doing that, post back, or just read the Nvidia's README that's online, it's really good.

And post back any success (or failure).

-Good Luck

Fred Hernandez
  Reply With Quote
Old 08-06-02, 04:59 AM   #11
ziphnor
Registered User
 
Join Date: Aug 2002
Posts: 14
Default

I will try the source RPMs later today, i just hope it works, im not in the mood for another reinstall

EDIT: Btw, do i need the kernel source installed to rebuild the kernel driver? Because i dont have it installed, so if i need it, do anyone know the filename(i installed Suse by downloading everything except the source to a local drive).

Last edited by ziphnor; 08-06-02 at 06:20 AM.
ziphnor is offline   Reply With Quote
Old 08-06-02, 09:01 AM   #12
deranonyme
Guest
 
Posts: n/a
Default

Hi

i had also problems with a crash and a black screen. I used
Option "NvAGP" "0"
now it works.

mfg Frank
  Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
Geforce 440 Go, SuSE 8.0, and new Nvidia drivers loudawg NVIDIA Linux 4 06-01-04 01:54 AM
My SuSE 8.0 just totally BROKE. Help please!!! sephiroth762 NVIDIA Linux 6 10-09-02 03:30 PM
SuSe 8.0 Problems. GaMMa NVIDIA Linux 19 09-26-02 07:51 AM
Newbie - Compiling my own for SuSe 8.0 jocephus19 NVIDIA Linux 5 09-01-02 10:38 PM
how to boot SuSe 8.0 to console? chrisr NVIDIA Linux 8 08-19-02 10:08 PM

All times are GMT -5. The time now is 04:48 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.